View Issue Details

IDProjectCategoryView StatusLast Update
0022599CommunityOCCT:Data Exchangepublic2014-10-09 18:40
Reporterszy Assigned Toabv  
PrioritynormalSeverityfeature 
Status closedResolutionduplicate 
OSAll 
Fixed in Version6.6.0 
Summary0022599: XCAFDoc_ShapeTool extended with two methods - SetAutoNaming() and AutoNaming().
DescriptionRLN contribution (RLN_fix450)
- Summary: XCAFDoc_ShapeTool extended with two methods - SetAutoNaming() and
AutoNaming().
- Detailed description: Auto-naming is used to auto-generate names for
(sub-)shapes. Earlier it was controlled by a pre-processor macro (#define
AUTONAMING), which was defined in source code. Thus, the XDE document was
contaminated with names not present in the original imported files.
The fix makes it a run-time parameter which is on by default, preserving
previous behavior. Unfortunately, it had to be made a static member function as
it is used by other static members.

===============================================
Branch OCC22599_XcafdocAutonaming is created.
TagsNo tags attached.
Test case number

Relationships

duplicate of 0023595 closedRoman Lygin XCAFDoc_ShapeTool extended with two methods - SetAutoNaming() and AutoNaming() 

Activities

pdn

2014-10-09 18:29

reporter   ~0032933

Already in master, to be closed

abv

2014-10-09 18:40

manager   ~0032940

Fixed by 0023595

Issue History

Date Modified Username Field Change
2011-08-02 11:12 bugmaster Category OCCT:DTE => OCCT:Data Exchange
2011-11-24 16:36 szy Assigned To bugmaster => pdn
2011-11-24 16:36 szy Status acknowledged => assigned
2011-11-24 16:36 szy Resolution suspended => reopened
2011-11-24 16:36 szy Fixed in Version EMPTY =>
2011-11-24 16:36 szy Description Updated
2014-10-09 18:29 pdn Note Added: 0032933
2014-10-09 18:29 pdn Assigned To pdn => abv
2014-10-09 18:29 pdn Status assigned => resolved
2014-10-09 18:39 abv Relationship added duplicate of 0023595
2014-10-09 18:40 abv Note Added: 0032940
2014-10-09 18:40 abv Status resolved => closed
2014-10-09 18:40 abv Resolution reopened => duplicate
2014-10-09 18:40 abv Fixed in Version => 6.6.0