MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0022597Community[OCCT] OCCT:Data Exchangepublic2011-06-10 18:162014-10-09 18:42
Reporterszy 
Assigned Toabv 
PrioritynormalSeverityfeature 
StatusclosedResolutionduplicate 
PlatformOSAllOS Version
Product Version 
Target VersionFixed in Version[OCCT] 6.6.0 
Summary0022597: IGESCAFControl_Writer extended with method Transfer()
DescriptionRLN contribution (RLN_fix445)
- Summary: IGESCAFControl_Writer extended with method Transfer() accepting
TDF_LabelSequence and Write*() also accept TDF_LabelSequence
- Detailed description: This API makes IGESCAFControl_Writer more consistent
with STEPCAFControl_Writer and allows to export only sub-part of the XDE
document (e.g. only root shapes belonging to one layer, etc).
WriteNames() and WriteLayers() were not re-designed and they still iterate over
entire document. However given that there are no resulting entities for shapes
not referred to by TDF_LabelSequence, not affected layers and names will not be
transferred.

===================================================
Branch OCC22597_IgescafcontrolTransferSequence is created.
TagsNo tags attached.
Test case number
Attached Files

- Relationships
duplicate of 0023590closedbugmaster IGESCAFControl_Writer extended to accept TDF_LabelSequence 

-  Notes
(0032934)
pdn (developer)
2014-10-09 18:31

Already in master. To be closed.
(0032945)
abv (manager)
2014-10-09 18:42

Fixed by 0023590

- Issue History
Date Modified Username Field Change
2011-08-02 11:12 bugmaster Category OCCT:DTE => OCCT:Data Exchange
2011-11-24 15:56 szy Assigned To bugmaster => pdn
2011-11-24 15:56 szy Status acknowledged => assigned
2011-11-24 15:56 szy Resolution suspended => reopened
2011-11-24 15:56 szy Fixed in Version EMPTY =>
2011-11-24 15:56 szy Description Updated View Revisions
2014-10-09 18:31 pdn Note Added: 0032934
2014-10-09 18:31 pdn Assigned To pdn => abv
2014-10-09 18:31 pdn Status assigned => resolved
2014-10-09 18:41 abv Relationship added duplicate of 0023590
2014-10-09 18:42 abv Note Added: 0032945
2014-10-09 18:42 abv Status resolved => closed
2014-10-09 18:42 abv Resolution reopened => duplicate
2014-10-09 18:42 abv Fixed in Version => 6.6.0


Copyright © 2000 - 2019 MantisBT Team
Powered by Mantis Bugtracker