MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0022570Community[OCCT] OCCT:Data Exchangepublic2011-06-03 12:592013-04-29 15:23
Reporterszy 
Assigned Tobugmaster 
PrioritynormalSeverityfeature 
StatusclosedResolutionfixed 
PlatformOSAllOS Version
Product Version[OCCT] 6.5.0 
Target Version[OCCT] 6.6.0Fixed in Version[OCCT] 6.6.0 
Summary0022570: Extending XCAFPrs_AISObject to enable customization of default color
DescriptionRLN contribution:
fix215
Declaring method Compute as protected in XCAFPrs_AISObject
- Detailed description: Declaring protected instead of private enables
subclassing of this class

fix365
- Summary: Extending XCAFPrs_AISObject to enable customization of default color
- Detailed description: virtual DefaultStyle() method added.
        Note that default style object has not been made a data member to avoid
memory consumption
===========
Branch OCC22570_XCAFPrsDfltStyle is created.

TagsNo tags attached.
Test case number
Attached Files

- Relationships
duplicate of 0023596closedRoman Lygin Extending XCAFPrs_AISObject to enable customization of default color 

-  Notes
(0023554)
abv (manager)
2013-03-01 21:41

Should be closed along with 0023596
(0023567)
pdn (developer)
2013-03-04 09:08

Agree, please close
(0023607)
bugmaster (administrator)
2013-03-07 10:08

Problem has been corrected by fix fot 0023596

- Related Changesets
occt: master 576ab394
Timestamp: 2012-11-28 09:50:28
Author: Roman Lygin
Details ] Diff ]
0023596: Extending XCAFPrs_AISObject to enable customization of default color
mod - src/XCAFPrs/XCAFPrs_AISObject.cdl Diff ] File ]
mod - src/XCAFPrs/XCAFPrs_AISObject.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2011-08-02 11:12 bugmaster Category OCCT:DTE => OCCT:Data Exchange
2011-11-24 15:28 szy Assigned To bugmaster => pdn
2011-11-24 15:28 szy Status acknowledged => assigned
2011-11-24 15:28 szy Resolution suspended => reopened
2011-11-24 15:28 szy Product Version => 6.5.0
2011-11-24 15:28 szy Fixed in Version EMPTY =>
2011-11-24 15:28 szy Target Version => 6.5.3
2011-11-24 15:28 szy Description Updated View Revisions
2012-03-12 07:34 abv Target Version 6.5.3 => 6.5.4
2012-10-23 19:26 abv Target Version 6.5.4 => 6.6.0
2013-03-01 21:39 abv Relationship added duplicate of 0023596
2013-03-01 21:40 abv Changeset attached => occt master 576ab394
2013-03-01 21:41 abv Note Added: 0023554
2013-03-01 21:41 abv Status assigned => feedback
2013-03-01 21:41 abv Target Version 6.6.0 => 6.7.0
2013-03-04 09:08 pdn Note Added: 0023567
2013-03-04 09:08 pdn Status feedback => resolved
2013-03-04 09:56 abv Assigned To pdn => bugmaster
2013-03-04 09:56 abv Status resolved => feedback
2013-03-07 10:08 bugmaster Status feedback => tested
2013-03-07 10:08 bugmaster Note Added: 0023607
2013-03-07 10:08 bugmaster Status tested => verified
2013-03-07 10:08 bugmaster Resolution reopened => fixed
2013-03-07 10:08 bugmaster Target Version 6.7.0 => 6.6.0
2013-04-23 13:35 user533 Status verified => closed
2013-04-29 15:23 user533 Fixed in Version => 6.6.0


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker