MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0022567Community[OCCT] OCCT:Modeling Algorithmspublic2011-06-02 20:522012-04-03 19:16
Reporterszy 
Assigned Tobugmaster 
PrioritynormalSeverityfeature 
StatusclosedResolutionfixed 
PlatformOSAllOS Version
Product Version 
Target Version[OCCT] 6.5.3Fixed in Version[OCCT] 6.5.3 
Summary0022567: Speed up of math_FunctionSetRoot (used in Extrema)
DescriptionRLN contribution. Detailed description:
      - Excluding recalculation in points which did not progress during iteration
      - Sqrt replaced with sqrt
      - minimized use of sqrt
      - static variable mydebug use surrounded with #ifdef DEB
      - minimized use of Abs in Bounds()
Additional information
and documentation updates
Version 2 (correction from jgv)

Updating of function F (math_FunctionSetWithDerivatives) by the last value of solution was added before all calls of method GetStateNumber (if needed)

Modified files:

math_FunctionSetRoot.cxx

Modified methods:

void math_FunctionSetRoot::Perform
TagsNo tags attached.
Test case numberTest case is not required
Attached Files

- Relationships

-  Notes
(0017571)
kgv (developer)
2011-06-15 13:34

SVN branch http://svn/svn/occt/branches/OCC22567_MathOptimization [^] for this BUG
was reviewed.
- Unnecessary debug outputs should be completelly removed.
- Changes in sources should not be tracked in files themselves.
- Comment text should be indented from //.

Remarks was fixed and integrated into bug branch.
Patch is ready for testing.
(0017572)
ycy (tester)
2011-07-08 14:36
edited on: 2011-11-22 17:59

Dear BugMaster,
SVN branch (http://svn/svn/occt/branches/OCC22567_MathOptimization [^]) was
testing, test results were compared with KAS:dev:products-651-opt

Regressions were not found
Test not necessary this branch

See results in /QADisk/OCCTtests/KAS/dev/ycy-products-2_05072011/lin
See reference results in
/QADisk/occttests/results/KAS/dev/products-651-opt_01062011/lin
See test cases in /QADisk/occttests/tests/ED
N.B. In order to launch testing case you can make use the following instructions
http://sbu.nnov.opencascade.com/maintenance/main_certification_te.html [^]

(0017573)
bugmaster (administrator)
2011-07-08 21:17

Fix has been integrated to occt repository
Date: 2011-07-08 19:14:20 +0400 (Fri, 08 Jul 2011)
New Revision: 8663

Modified:
   trunk/src/math/math_FunctionSetRoot.cxx
Log:
OCC22567 Speed up of math_FunctionSetRoot (used in Extrema)
Developed by : RLN and KGV
(0017574)
ycy (tester)
2011-07-21 15:09

Dear Kirill
During re-testing SVN branch
(http://svn/svn/occt/branches/OCC22567_MathOptimization [^]) in chl 919 I1 (
Uncorrect work DRAW command "proj" in version dev ) regression was found
Best regards, Yuri
(0017575)
kgv (developer)
2011-07-21 17:45

If problem caused by this patch than I suggest to revert changes from TRUNK.

Notice that I probably will NOT investigate this regression in nearest future
because I'm not familiar within changed algorithm and suggested optimisations.
(0017576)
bugmaster (administrator)
2011-07-22 14:00

Modified:
   trunk/src/math/math_FunctionSetRoot.cxx
Log:
Rollback integration
OCC22567 Speed up of math_FunctionSetRoot (used in Extrema)
Developed by : RLN and KGV
(0018068)
jgv (developer)
2011-09-02 14:37

SVN branch http://svn/svn/occt/branches/OCC22567 [^] is ready to be reviewed
(0018742)
abv (manager)
2011-12-05 15:19

I have only two minor review remarks:

- Removed debug printouts in math_FunctionSetRoot.cxx could be worth keeping in commented state, instead of removal, for possible use

- Replacement of call to Sqrt() (OCCT wrapper) to sqrt() (C math function) should be reverted: we have OCCT wrappers in order to be able to add protections in them, and it is not wise to avoid using them

Apart of this, the correction looks Ok and is ready for testing
(0018858)
jgv (developer)
2011-12-15 13:11

SVN branch http://svn/svn/occt/branches/22567 [^] is ready for testing.
(0018862)
abv (manager)
2011-12-15 15:49

Please comment out couts and variable "debug"
(0019071)
jgv (developer)
2012-01-10 15:36

SVN branch http://svn/svn/occt/branches/22567 [^] is ready for testing. Please, take sources from the new branch "22567".
(0019077)
abv (manager)
2012-01-10 17:43

I have merged the branch with trunk and integrated a change to take into account my previous review remark: debug printouts to cout are packed to macro and disabled
(0019119)
apn (administrator)
2012-01-13 17:52

Dear BugMaster,
    Workbench apn-22567-occt was created from SVN branch http://svn/svn/occt/branches/22567 [^] [^]
   (and apn-22567-products from trunk) and compiled on Linux platform.
    
    There are not regressions in apn-22567-products regarding to KAS:dev:products-20111229-opt.

    There several unstable tests:
chl 934 S8
pkv 913 A1
    
    See results in /QADisk/occttests/results/KAS/dev/apn-22567-products_13012012/lin
    See reference results in /QADisk/occttests/results/KAS/dev/products-20111229-opt_29122011/lin
    See test cases in /QADisk/occttests/tests/ED
(0019124)
bugmaster (administrator)
2012-01-13 20:35

Integrated to occt repository

Date: 2012-01-13 20:25:51 +0400 (Fri, 13 Jan 2012)
New Revision: 10039

Modified:
   trunk/src/math/math_FunctionSetRoot.cxx

- Related Changesets
occt: master 3d166d31
Timestamp: 2011-07-08 15:14:20
Author: RLN and KGV
Committer: bugmaster
Details ] Diff ]
OCC22567 Speed up of math_FunctionSetRoot (used in Extrema)
mod - src/math/math_FunctionSetRoot.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2011-07-05 17:19 kgv CC => kgv
2011-07-08 15:51 bugmaster Status closed => assigned
2011-07-08 15:51 bugmaster Resolution suspended => @0@
2011-07-08 15:52 bugmaster Assigned To bugmaster => kgv
2011-07-08 15:52 bugmaster Status assigned => resolved
2011-07-08 21:17 bugmaster Status resolved => verified
2011-07-20 19:01 bugmaster Assigned To kgv => bugmaster
2011-07-20 19:01 bugmaster Status verified => assigned
2011-07-20 19:01 bugmaster Assigned To bugmaster => ycy
2011-07-21 15:09 ycy Assigned To ycy => kgv
2011-07-21 17:46 bugmaster Assigned To kgv => jgv
2011-08-02 11:31 bugmaster Category OCCT:MOA => OCCT:Modeling Algorithms
2011-09-02 14:31 jgv Fixed in Version EMPTY =>
2011-09-02 14:31 jgv Description Updated View Revisions
2011-09-02 14:31 jgv Additional Information Updated View Revisions
2011-09-02 14:37 jgv Note Added: 0018068
2011-09-02 14:37 jgv Status assigned => resolved
2011-09-02 15:03 jgv Assigned To jgv => abv
2011-09-21 14:21 szy Target Version => 6.5.3
2011-11-22 17:59 szy Note Edited: 0017572 View Revisions
2011-11-25 11:57 szy Description Updated View Revisions
2011-12-05 15:19 abv Note Added: 0018742
2011-12-05 15:19 abv Assigned To abv => jgv
2011-12-05 15:19 abv Status resolved => assigned
2011-12-15 13:11 jgv Note Added: 0018858
2011-12-15 13:11 jgv Status assigned => resolved
2011-12-15 14:24 jgv Status resolved => reviewed
2011-12-15 15:49 abv Note Added: 0018862
2011-12-15 15:49 abv Status reviewed => assigned
2012-01-10 15:35 jgv Status assigned => resolved
2012-01-10 15:36 jgv Note Added: 0019071
2012-01-10 15:36 jgv Status resolved => reviewed
2012-01-10 17:43 abv Note Added: 0019077
2012-01-13 17:52 apn Note Added: 0019119
2012-01-13 17:53 apn Test case number => Test case is not required
2012-01-13 17:53 apn Status reviewed => tested
2012-01-13 20:35 bugmaster Note Added: 0019124
2012-01-13 20:35 bugmaster Status tested => verified
2012-01-13 20:35 bugmaster Resolution open => fixed
2012-03-29 17:26 bugmaster Changeset attached => occt master 3d166d31
2012-04-03 19:16 abv Assigned To jgv => Roman Lygin


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker