MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0022318Community[OCCT] OCCT:Meshpublic2011-03-11 18:432012-11-09 10:07
Reporterabv 
Assigned Tobugmaster 
PrioritynormalSeveritytrivial 
StatusclosedResolutionfixed 
PlatformOSAllOS Version
Product Version 
Target VersionFixed in Version[OCCT] 6.5.1 
Summary0022318: Regression (since OCCT 6.3.1): bad shading of small cylinder (forum thread 20083)
DescriptionThe problem is reported on OCC Forum thread 20083:
http://www.opencascade.org/org/forum/thread_20083 [^]

In OCCT 6.5.0, if compound consisting of small and big cylinders is displayed in
shading mode (not in wireframe first!), mesh on small cylinder is very rough.

Use attached script to reproduce the problem
Additional information
and documentation updates
Documentation remark, added by OAN 2011-04-04 10:38:51:

New features:
No
Improvements:
The triangulation of small cylinder builds right now.
Changes:
The triangulator takes into account the type of edge. If it has a circle-like
type a number of vertices may be more than two.
Modified entities:
Package BRepMesh: BRepMesh_FastDiscret.cxx (BRepMesh_FastDiscret.cdl) - small
code change
TagsNo tags attached.
Test case number
Attached Files? file icon forum20083.tcl (288 bytes) 2011-03-11 18:43
gz file icon oan-OCC22318-v1.tar.gz (9,681 bytes) 2011-04-04 12:22
gz file icon oan-OCC22318-v2.tar.gz (9,681 bytes) 2011-04-11 17:13
gz file icon oan-OCC22318-v3.tar.gz (9,477 bytes) 2011-04-14 13:20

- Relationships
related to 0022138closedbugmaster Open CASCADE Remove *.gxx files from Mesh algorithm 
related to 0022383closedbugmaster Open CASCADE Four and more points at least on curve 

-  Notes
There are no notes attached to this issue.

- Related Changesets
occt: master ae075275
Timestamp: 2011-05-19 10:48:19
Author: pdn
Committer: bugmaster
Details ] Diff ]
OCC22318 Regression (since OCCT 6.3.1): bad shading of small cylinder (forum thread 20083)
mod - src/BRepMesh/BRepMesh_FastDiscret.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2011-03-14 15:25 bugmaster Status closed => assigned
2011-03-14 15:25 bugmaster Resolution suspended => @0@
2011-03-14 15:30 bugmaster Assigned To bugmaster => pdn
2011-04-04 12:15 bugmaster Assigned To pdn => oan
2011-04-04 12:23 oan OtherBugsDependingOnThis => 22138
2011-04-04 12:35 oan Status assigned => resolved
2011-04-13 15:44 mkv Status resolved => assigned
2011-04-14 10:26 oan OtherBugsDependingOnThis => 22383
2011-04-14 13:22 oan Status assigned => resolved
2011-04-28 12:12 oan BugsThisDependsOn => 22302
2011-04-29 15:17 mkv Status resolved => assigned
2011-05-19 16:47 bugmaster Status assigned => tested
2011-05-19 16:48 bugmaster Status tested => verified
2011-07-07 14:28 oan BugsThisDependsOn 22302 =>
2011-08-02 11:24 bugmaster Category OCCT:VIZ => OCCT:Visualization
2011-12-01 11:20 szy Description Updated View Revisions
2011-12-01 11:20 szy Additional Information Updated View Revisions
2012-03-29 17:26 bugmaster Changeset attached => occt master ae075275
2012-11-09 10:07 abv Category OCCT:Visualization => OCCT:Mesh


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker