MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0022238Community[OCCT] OCCT:Data Exchangepublic2011-02-03 10:562012-03-29 17:26
Reporterszy 
Assigned Tobugmaster 
PrioritynormalSeveritytrivial 
StatusclosedResolutionfixed 
PlatformOSAllOS Version
Product Version 
Target VersionFixed in Version[OCCT] 6.5.1 
Summary0022238: Bug during step file importation
DescriptionThe description copied from forum. Step file is attached.
==========================================================
Hi, I'm importing the attached STEP file. The result ought to be a circularly
trimmed plane, translated along its normal vector by 2.0 units. But actually the
plane's normal is still pointing along the z axis, but the translation is done
along the x axis!

In line 104 of test.stp, the translation is defined
#77=CARTESIAN_POINT('S2->Labor',(0.,0.,2.));
After importing the STEP file in OCC, I took a look at the transformations. The
plane's root compound shape reports as the translational part of its TopLoc_Location
Position(-2, -0, -0)
the TopLoc_Location's rotation matrix on the other hand has rows
Row 1(1, 0, 0)
Row 2(0, 1, 0)
Row 3(0, 0, 1)
So obviously the directions x and z are not swapped.
The TopLoc_Location contains only a single Datum3d object and the coumpound
shape has no superior node, which could be responsible for a xz-swap.

When I re-export the file from Open CASCADE to STEP again, it prompts a line
0000016 = CARTESIAN_POINT('',(-2,,0,E+000,0,E+000));

Rhino3d and other CAD programs are correctly importing the file (resulting in a
circular trimmed plane, translated along it's normal vector by 2.0 units)
TagsNo tags attached.
Test case numberxstp 410 C8
Attached Files? file icon test.stp (8,407 bytes) 2011-02-03 10:56
cxx file icon stepcontrol_actorread.cxx (73,333 bytes) 2011-05-03 17:36

- Relationships

-  Notes
(0016789)
gka (developer)
2011-05-03 19:49

After analysis initial file test.stp in different systems such as:
"Rhinoceros 4.0(Evaluation version)",
"Creo Elements/Direct Modeling Personal Edition 3.0"
was found that assembly for this case was translated incorrectly.
Attached corrected file performs translation of assembly the same way as tools
listed above.
(0016790)
gka (developer)
2011-05-03 19:55

Dear Igor.

Could you please add this case in the test base because this case is special and
it differs from all existent test cases.
(0016791)
ycy (tester)
2011-05-16 19:13
edited on: 2011-11-25 11:21

Dear BugMaster,
Workbench KAS:dev:OCC22238-v1-opt has been created from
stepcontrol_actorread.cxx and compiled on Linux platform.
There are following regressions(/differences) in OCC22238-v1-opt regarding to
KAS:dev:products-20110428-opt

Regressions were not found.

See results in /KASDev/OCCTtests/KAS/dev/OCC22238-v1-opt_13052011/lin
See reference results in
/QADisk/occttests/results/KAS/dev/products-20110428-opt_29042011/lin
See test cases in /QADisk/occttests/tests/ED
N.B. In order to launch testing case you can make use the following instructions
http://sbu.nnov.opencascade.com/maintenance/main_certification_te.htm [^]


- Related Changesets
occt: master d2a98d71
Timestamp: 2011-05-19 10:33:49
Author: gka
Committer: bugmaster
Details ] Diff ]
OCC22238 Bug during step file importation
mod - src/STEPControl/STEPControl_ActorRead.cxx Diff ] File ]

- Issue History
Date Modified Username Field Change
2011-02-03 12:48 bugmaster groupset1 => 4096
2011-02-03 12:48 bugmaster Customer => Community
2011-04-06 18:52 bugmaster Assigned To bugmaster => szy
2011-04-06 18:52 bugmaster Status new => assigned
2011-04-13 14:21 bugmaster Assigned To szy => gka
2011-05-03 19:49 gka Status assigned => resolved
2011-05-19 16:34 bugmaster Status resolved => verified
2011-08-02 11:12 bugmaster Category OCCT:DTE => OCCT:Data Exchange
2011-09-07 11:38 miv Test case number => xstp 410 C8
2011-09-07 11:38 miv Description Updated View Revisions
2011-11-25 11:21 szy Note Edited: 0016791 View Revisions
2012-03-29 17:26 bugmaster Changeset attached => occt master d2a98d71


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker