MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0022146Open CASCADE[OCCT] OCCT:Modeling Algorithmspublic2010-12-14 13:482018-07-07 02:34
Reporterpdn 
Assigned Toabv 
PrioritynormalSeverityfeature 
StatusassignedResolutionopen 
PlatformOSAllOS Version
Product Version 
Target Version[OCCT] 7.4.0*Fixed in Version 
Summary0022146: Integration of OCC in-house parallelization tool
DescriptionIntegration of MP (Multy Process) data and process into OSD. Detailed
documentation is given in hxx
TagsNo tags attached.
Test case number
Attached Fileszip file icon OCC22146_v1_pdn.zip (10,453 bytes) 2010-12-14 11:49
zip file icon OSD_MProcess_new.zip (9,592 bytes) 2014-08-05 12:26

- Relationships
related to 0026365newabv Open CASCADE Optimization of work of OSD_Parallel class members 
related to 0029935verifiedbugmaster Open CASCADE Foundation Classes - introduce OSD_ThreadPool class defining a thread pool 
related to 0024826closedbugmaster Community Wrapping of parallelisation algorithms 

-  Notes
(0030571)
abv (manager)
2014-08-05 12:25

It seems there is still a demand for hawing own paralleling tool, to be used if TBB is not wanted
(0030572)
abv (manager)
2014-08-05 12:27

OSD_MProcess_new.zip contains most up-to-date version of in-house tool
(0030870)
azn (developer)
2014-08-19 10:51

Please review the initial integration of parallelization wrapping. Brunch CR24826.
(0030992)
abv (manager)
2014-08-21 12:54

As we discussed, apart of a number of syntax / coding remarks, there are a few major issues with proposed implementation:

- it allocates (dynamically) an object for each element of the sequence of objects to be processed, this might be too expensive

- there seem to be no actual difference between ForEach and For, perhaps single For will be sufficient

- it is not clear how this will work if some cycle executed in parallel starts another (nested) parallel cycle. Current implementation will obviously start new N threads each time, this can be not optimal. Perhaps we should have N threads permanently allocated (as TBB likely does) and organize their work so as to avoid contention in case of nested calls.
(0059665)
abv (manager)
2016-11-01 06:25

The tool is implemented in 0024826 (class OSD_Parallel), but remarks above seems to be still relevant.

- Issue History
Date Modified Username Field Change
2010-12-14 13:49 pdn CC => msv, agv, abv
2010-12-14 14:33 bugmaster Status new => closed
2010-12-14 14:33 bugmaster Resolution @0@ => unable to reproduce
2011-08-02 11:31 bugmaster Category OCCT:MOA => OCCT:Modeling Algorithms
2014-08-05 12:25 abv Note Added: 0030571
2014-08-05 12:25 abv Assigned To bugmaster => azn
2014-08-05 12:25 abv Status closed => assigned
2014-08-05 12:26 abv File Added: OSD_MProcess_new.zip
2014-08-05 12:26 abv Fixed in Version EMPTY =>
2014-08-05 12:26 abv Target Version => 6.8.0
2014-08-05 12:26 abv Description Updated View Revisions
2014-08-05 12:27 abv Note Added: 0030572
2014-08-05 12:27 abv Relationship added related to 0025115
2014-08-05 12:28 abv Relationship added related to 0024826
2014-08-05 19:29 abv Severity trivial => feature
2014-08-05 19:29 abv Resolution unable to reproduce => open
2014-08-19 10:51 azn Assigned To azn => abv
2014-08-19 10:51 azn Note Added: 0030870
2014-08-21 12:43 abv Assigned To abv => azn
2014-08-21 12:54 abv Note Added: 0030992
2014-10-29 13:46 abv Target Version 6.8.0 => 7.1.0
2016-01-08 01:27 abv Assigned To azn => abv
2016-10-28 16:28 msv Target Version 7.1.0 => 7.2.0
2016-11-01 06:25 abv Note Added: 0059665
2017-07-20 12:37 kgv Relationship added related to 0026365
2017-07-21 10:35 msv Target Version 7.2.0 => 7.3.0
2017-12-05 17:09 msv Target Version 7.3.0 => 7.4.0*
2018-07-07 02:34 kgv Relationship added related to 0029935


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker