MantisBT
Mantis Bug Tracker Workflow

View Issue Details Jump to Notes ] Related Changesets ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0022027Community[OCCT] OCCT:Modeling Algorithmspublic2010-09-22 14:202013-04-29 15:24
Reporterszy 
Assigned Toapn 
PrioritynormalSeveritytrivial 
StatusclosedResolutionfixed 
PlatformOSAllOS Version
Product Version 
Target Version[OCCT] 6.6.0Fixed in Version[OCCT] 6.6.0 
Summary0022027: <bop> command between two faces raises exception
DescriptionSee below the post from Forum explaining the problem of new boolean operations bug.

"How to catch this exception/error thrown by the source code. It is not being
caught by the usual procedure(catching Standard_Failure).
try this in test harness,
circle c 0 0 0 25
ellipse e 0 0 0 25 10
mkedge c c
mkedge e e
wire w1 c
wire w2 e
mkplane f1 w1
mkplane f2 w2
# trying to cut the smaller face with the larger face
bop f1 f2
BOPTools_PaveFiller::DoSDEdges()=> can not find SplitIndex

Is it a bug ? "
TagsNo tags attached.
Test case numberbugs modalg_5 bug22027
Attached Files

- Relationships
related to 0021762closedemv Open CASCADE Integration new Boolean Operation algorithm to OCC 

-  Notes
(0016013)
emv (developer)
2011-04-07 17:10

Fix for this bug is in the patch pkv913A1_v3.zip attached to the bug OCC21762
http://bugtracker.opencascade.com/show_bug.cgi?id=21762&attributes=attachment [^]
(0023656)
emv (developer)
2013-03-12 10:38

Fixed in current version of OCCT.
(0023671)
apn (administrator)
2013-03-12 15:38

Branch CR22027 was created from current state of master. The problem is fixed.
Test case - bugs/modalg_5/bug22027 - OK
Branch contains only test case and will be integrated.

- Related Changesets
occt: master 1e6b1940
Timestamp: 2013-03-12 11:36:30
Author: apn
Details ] Diff ]
0022027: <bop> command between two faces raises exception

Added test case for issue 22027.
add - tests/bugs/modalg_5/bug22027 Diff ] File ]

- Issue History
Date Modified Username Field Change
2010-10-06 19:00 bugmaster Status closed => assigned
2010-10-06 19:00 bugmaster Resolution suspended => @0@
2010-10-06 19:00 bugmaster Assigned To bugmaster => jgv
2011-02-25 12:16 bugmaster Assigned To jgv => emv
2011-04-07 17:21 emv Status assigned => resolved
2011-04-07 17:32 bugmaster OtherBugsDependingOnThis => 21762
2011-08-02 11:31 bugmaster Category OCCT:MOA => OCCT:Modeling Algorithms
2012-02-17 12:34 abv Status resolved => assigned
2013-03-12 10:38 emv Note Added: 0023656
2013-03-12 10:38 emv Assigned To emv => mkv
2013-03-12 10:38 emv Status assigned => resolved
2013-03-12 10:46 abv Status resolved => feedback
2013-03-12 15:38 apn Note Added: 0023671
2013-03-12 15:38 apn Test case number => bugs modalg_5 bug22027
2013-03-12 15:38 apn Assigned To mkv => bugmaster
2013-03-12 15:38 apn Status feedback => tested
2013-03-12 15:38 apn Fixed in Version EMPTY =>
2013-03-12 15:38 apn Description Updated View Revisions
2013-03-12 15:58 abv Target Version => 6.6.0
2013-03-18 20:48 apn Changeset attached => occt master 1e6b1940
2013-03-18 20:48 apn Assigned To bugmaster => apn
2013-03-18 20:48 apn Status tested => verified
2013-04-23 13:35 user533 Status verified => closed
2013-04-29 15:24 user533 Fixed in Version => 6.6.0


Copyright © 2000 - 2018 MantisBT Team
Powered by Mantis Bugtracker