View Issue Details

IDProjectCategoryView StatusLast Update
0020515Open CASCADEOCCT:Modeling Algorithmspublic2017-11-09 10:16
Reporterepa Assigned Toszy  
PrioritynormalSeveritytrivial 
Status closedResolutionfixed 
OSAll 
Fixed in Version6.3.1 
Summary0020515: OCC parallelization
DescriptionIntegration of the parallel fixes proposed by Roman Lygin.
TagsNo tags attached.
Test case number

Attached Files

  • epaOCC20515.tar.gz (566,050 bytes)
  • epaOCC20515-v2.tar.gz (485,488 bytes)
  • epaOCC20515-v3.tar.gz (125,083 bytes)
  • epaOCC20515-v4.tar.gz (90,224 bytes)
  • abvOCC20515-v5.tar.gz (23,370 bytes)
  • abvOCC20515-v6.tar.gz (31,063 bytes)
  • abvOCC20515-v7.tar.gz (33,675 bytes)
  • abvOCC20515-v8.tar.gz (33,570 bytes)

Relationships

parent of 0029304 closedbugmaster Draw Harness, DBRep_DrawableShape - fix inappropriate use of unordered map 

Activities

2008-10-13 15:49

 

epaOCC20515.tar.gz (566,050 bytes)

epa

2008-10-13 18:06

developer   ~0014024

Dear Igor,
Please test this tar in the following way:
1. create bench without parent
2. copy all from ros
3. put adm
4. compile

BR,
Katya

2008-10-15 17:07

 

epaOCC20515-v2.tar.gz (485,488 bytes)

epa

2008-10-15 19:12

developer   ~0014026

Dear bugmaster,

Please test this fix by creating bench with the previous Fix as a parent

2008-10-16 12:55

 

epaOCC20515-v3.tar.gz (125,083 bytes)

epa

2008-10-16 14:59

developer   ~0014028

one static variable protected by mutex remains. To be removed later.

2008-10-17 12:38

 

epaOCC20515-v4.tar.gz (90,224 bytes)

epa

2008-10-17 15:34

developer   ~0014031

Please recompile in DEBUG mode for debug at monday

epa

2008-10-20 19:46

developer   ~0014032

In debug mode in ros and in new version the Standard_OutOfRange exception is
raised. So, in this use case the exit over the array range is appeared in
Dbrep_DrawaibleShape (in case of internal edges).

In optimize mode the out of rage is not checked and we have problem in both
cased by in old version the problem is hidden.

I propose to create a new bug and to fix it with appropriate responsible.

2008-10-22 12:59

 

abvOCC20515-v5.tar.gz (23,370 bytes)

abv

2008-10-22 15:02

manager   ~0014036

I have attached revised version of the first fix101, which includes fix for
discovered regression in DRAW (made by EPA), and also parts of fix118 affecting
generation of headers by WOK (EDL files). Thus this fix should contain all
changes affecting WOK. Please use it to re-test root workbench.

2008-10-22 16:01

 

abvOCC20515-v6.tar.gz (31,063 bytes)

abv

2008-10-22 18:03

manager   ~0014038

Sorry, please take updated version of the fix (v6): previous version lacks
changes in WOKTclTools package, in addition, EDL files in CPPClient are now
corrected following other changes

2008-10-22 18:06

 

abvOCC20515-v7.tar.gz (33,675 bytes)

abv

2008-10-23 11:34

manager   ~0014040

Dear Mikhail,

Please test only version v7 of the patch; other fixes will be added as separate
bugs

epa

2008-10-23 15:27

developer   ~0014041

Fixes 106 110 and 116 in the bag 20550. It is reccomended to integrate after
20550.

2008-10-24 09:20

 

abvOCC20515-v8.tar.gz (33,570 bytes)

Issue History

Date Modified Username Field Change
2008-10-13 18:06 epa CC => pdn, abv, szy
2008-10-22 10:46 bugmaster Assigned To bugmaster => szy
2008-10-22 10:46 bugmaster Status new => assigned
2009-01-30 18:35 bugmaster Status assigned => verified
2009-06-24 19:28 bugmaster Status verified => closed
2009-06-24 19:28 bugmaster Resolution @0@ => fixed
2011-08-02 11:31 bugmaster Category OCCT:MOA => OCCT:Modeling Algorithms
2017-11-09 10:16 kgv Relationship added parent of 0029304