View Issue Details

IDProjectCategoryView StatusLast Update
0000140Open CASCADEOCCT:Modeling Algorithmspublic2021-08-29 19:24
Reporterbugmaster Assigned Tomsv  
PrioritynoneSeveritytrivial 
Status assignedResolutionsuspended 
OSAll 
Target Version7.7.0 
Summary0000140: Fillet is created incorrectly on attached shape.
DescriptionRestore attached shape and try to put fillet by DRAW script below.

restore 5_L12.draw s
dset SCALE1 5
tscale s 0 0 0 SCALE1
explode s E
blend result s 4.5*SCALE1 s_4 4.5*SCALE1 s_5 4.5*SCALE1 s_1
explode result So
tcopy result_1 result
donly result
fsameparameter result
checkshape result
TagsNo tags attached.
Test case numberbugs modalg_1 bug140, bug140_2

Attached Files

  • 5_L12.draw (14,286 bytes)
  • 140-1.gif (25,192 bytes)
  • 140-2.gif (39,640 bytes)
  • fillet-wrinkle2.png (44,042 bytes)
  • fillet-wrinkle2-tcl-Common001.brep (307,488 bytes)
  • fillet-wrinkle2.tcl (155 bytes)
  • shape.gif (29,285 bytes)
  • bug140 (705 bytes)
  • bug140_2 (482 bytes)

Relationships

related to 0025918 newmsv Invalid result shape after blend operation 
related to 0032185 newmsv Modeling Algorithms - Bad fillet on an internal edge of a revolution 

Activities

2003-08-04 08:38

 

5_L12.draw (14,286 bytes)
140-1.gif (25,192 bytes)

2003-08-04 08:39

 

140-2.gif (39,640 bytes)

shoogen

2015-03-21 00:31

reporter  

fillet-wrinkle2.png (44,042 bytes)

shoogen

2015-03-21 00:32

reporter  

fillet-wrinkle2-tcl-Common001.brep (307,488 bytes)

shoogen

2015-03-21 00:32

reporter  

fillet-wrinkle2.tcl (155 bytes)

shoogen

2015-03-22 14:48

reporter   ~0038771

Might be related to 0025918

bugmaster

2016-09-15 15:19

administrator   ~0057822

Problem is reproduced on master 2016-09-08.
checkshape is BAD
3d image was attached.

bugmaster

2016-09-15 15:20

administrator  

shape.gif (29,285 bytes)

mkv

2017-09-14 17:38

tester  

bug140 (705 bytes)

mkv

2017-09-14 17:38

tester  

bug140_2 (482 bytes)

mkv

2017-09-14 17:39

tester   ~0070551

Problem is reproduced on the current master. Bopcheck hangs test.

Issue History

Date Modified Username Field Change
2002-01-23 19:01 bugmaster Assigned To bugmaster => jgv
2002-01-23 19:01 bugmaster Status new => assigned
2003-07-30 15:35 bugmaster Assigned To jgv => skv
2003-07-31 09:56 bugmaster Status assigned => closed
2003-07-31 09:56 bugmaster Resolution @0@ => unable to reproduce
2003-08-04 10:39 bugmaster Assigned To skv => bugmaster
2003-08-04 10:39 bugmaster Status closed => assigned
2003-08-04 10:39 bugmaster Resolution unable to reproduce => @0@
2003-08-04 10:40 bugmaster Assigned To bugmaster => skv
2003-08-11 11:37 bugmaster Assigned To skv => jgv
2003-09-30 16:32 mkk Assigned To jgv => skv
2004-03-09 15:55 bugmaster Status assigned => closed
2004-03-09 15:55 bugmaster Resolution @0@ => suspended
2004-03-09 15:55 bugmaster validate => 1
2011-08-02 11:31 bugmaster Category OCCT:MOA => OCCT:Modeling Algorithms
2015-03-21 00:31 shoogen File Added: fillet-wrinkle2.png
2015-03-21 00:32 shoogen File Added: fillet-wrinkle2-tcl-Common001.brep
2015-03-21 00:32 shoogen File Added: fillet-wrinkle2.tcl
2015-03-22 13:55 abv Assigned To skv => msv
2015-03-22 13:55 abv Status acknowledged => assigned
2015-03-22 13:55 abv Fixed in Version EMPTY =>
2015-03-22 13:55 abv Target Version => 7.1.0
2015-03-22 13:55 abv Description Updated
2015-03-22 14:48 shoogen Note Added: 0038771
2015-03-23 10:33 msv Relationship added related to 0025918
2016-09-15 15:19 bugmaster Note Added: 0057822
2016-09-15 15:20 bugmaster File Added: shape.gif
2016-10-28 12:16 msv Target Version 7.1.0 => 7.2.0
2017-07-24 09:32 msv Target Version 7.2.0 => 7.3.0
2017-09-14 17:38 mkv File Added: bug140
2017-09-14 17:38 mkv File Added: bug140_2
2017-09-14 17:39 mkv Test case number => bugs modalg_1 bug140, bug140_2
2017-09-14 17:39 mkv Note Added: 0070551
2017-12-05 17:08 msv Target Version 7.3.0 => 7.4.0
2019-08-12 16:37 msv Target Version 7.4.0 => 7.5.0
2020-09-14 22:58 msv Target Version 7.5.0 => 7.6.0
2021-03-18 15:16 asuraven Relationship added related to 0032185
2021-08-29 19:24 msv Target Version 7.6.0 => 7.7.0