MantisBT - Community
View Issue Details
0031574Community[OCCT] OCCT:Visualizationpublic2020-05-20 16:372020-05-22 13:22
hanneskr 
hanneskr 
normalmajor 
feedbackopen 
LinuxUbuntu20.04
[OCCT] 7.3.0 
 
0031574: Cannot run application using viewer Qt5/OCCT 7.3
After a system upgrade form ubuntu bionic to focal, I recompiled my program but it does not run. As soon as a viewer is created the propgram stops with the message:
X Error of failed request: GLXBadDrawable
  Major opcode of failed request: 154 (GLX)
  Minor opcode of failed request: 5 (X_GLXMakeCurrent)
  Serial number of failed request: 46
  Current serial number in output stream: 46

This error appears in the function Xv_Window.

I use the proprietary Nvidia driver for Linux (error appears in all version tested: 390, 440). The application works with the Nouveau driver.

The problem also appears with the "Tutorial" sample from OCC.
1. Install Ubuntu focal 20.04 with its OCCT 7.3 -dev packages
2. Install NVidia driver 440 (recommended)
3. Compile OCCT "Tutorial" sample
No tags attached.
png occt750dev_ubuntu20_04_qtiesample.png (93,121) 2020-05-20 19:14
https://tracker.dev.opencascade.org/
Issue History
2020-05-20 16:37hanneskrNew Issue
2020-05-20 16:37hanneskrAssigned To => kgv
2020-05-20 19:10kgvNote Added: 0092268
2020-05-20 19:10kgvAssigned Tokgv => hanneskr
2020-05-20 19:10kgvStatusnew => feedback
2020-05-20 19:14kgvFile Added: occt750dev_ubuntu20_04_qtiesample.png
2020-05-20 19:21hanneskrNote Added: 0092270
2020-05-20 19:24hanneskrNote Edited: 0092270bug_revision_view_page.php?bugnote_id=92270#r22976
2020-05-20 19:31kgvNote Added: 0092271
2020-05-20 19:32kgvNote Edited: 0092271bug_revision_view_page.php?bugnote_id=92271#r22978
2020-05-20 23:14hanneskrNote Added: 0092277
2020-05-20 23:26kgvNote Added: 0092278
2020-05-20 23:26kgvNote Edited: 0092278bug_revision_view_page.php?bugnote_id=92278#r22985
2020-05-21 01:05hanneskrNote Added: 0092279
2020-05-22 12:49hanneskrNote Added: 0092302
2020-05-22 13:22kgvNote Added: 0092303

Notes
(0092268)
kgv   
2020-05-20 19:10   
If NVIDIA driver fails, while Mesa driver works as expected, then why issue is reported to OCCT project?
(0092270)
hanneskr   
2020-05-20 19:21   
(edited on: 2020-05-20 19:24)
Because the problem only occurs with OCC programs.

Other programs that require GLX work fine.

(0092271)
kgv   
2020-05-20 19:31   
(edited on: 2020-05-20 19:32)
> Because the problem only occurs with OCC programs.
Well, that doesn't necessarily indicate that the problem is within the OCCT-based program. At least provided stack trace does not indicating problem location.

Have you tried CAD Assistant, by the way - does it crashes with the same error?

(0092277)
hanneskr   
2020-05-20 23:14   
Ok, I downloaded the CAD assistant AppImage from here: https://www.opencascade.com/content/cad-assistant [^]

That worked without any problem.
(0092278)
kgv   
2020-05-20 23:26   
So, it looks like a problem specific to Qt5 Widgets sample.

Could you build up-to-date OCCT development branch (master branch in git) and check is it is still reproducible?

(0092279)
hanneskr   
2020-05-21 01:05   
I just download and built the latest commit (4db6748)

The tutorial example works with this version as well.
(0092302)
hanneskr   
2020-05-22 12:49   
It looks like the issue has to do with Qt and it's build options.

I used a self-compiled Qt-5.14 and it does not work with that in Ubuntu Focal (though the same version worked in Bionic).
It works in Focal only if I use the system-provided Qt-5.12.

Weird.
(0092303)
kgv   
2020-05-22 13:22   
This might be related to Qt porting onto Wayland instead of X11.
I haven't checked their current state, but I think there might be new configure options for Qt.