MantisBT - Community
View Issue Details
0031435Community[OCCT] OCCT:Data Exchangepublic2020-03-17 17:402020-03-26 19:18
robertlipman 
dpasukhi 
normalcrash 
assignedopen 
WindowsVC++ 201564 bit
[OCCT] 7.3.0 
[OCCT] 7.5.0* 
0031435: Data Exchange - Problem importing STEP files
I submitted this problem via the contact form and Kirill responded. I'm not sure if I filled this form out correctly. We're using 7.4.2 to import STEP files. The problem is also seen in CAD Assistant.

These STEP files https://s3.amazonaws.com/nist-el/mfg_digitalthread/NIST-files-for-OCC.zip [^] do not open in CAD Assistant. The also do not work in our own software that uses the Open Cascade STEP processor.

For "sp7_04-do-242.stp" and "sp7_04-dx-242.stp" the problem seems to be with the LIMITS_AND_FITS entity. There is no problem with the entity. Blank values are valid. Adding values does not fix the problem. The only fix is to removed the entity. Other viewers do not have problems with these files.

For the third file, the problem is unknown. Other viewers do have a problem with this file.
No tags attached.
zip NIST-files-for-OCC.zip (1,579,413) 2020-03-17 17:40
https://tracker.dev.opencascade.org/
Issue History
2020-03-17 17:40robertlipmanNew Issue
2020-03-17 17:40robertlipmanAssigned To => gka
2020-03-17 17:40robertlipmanFile Added: NIST-files-for-OCC.zip
2020-03-18 11:16kgvSummaryProblem importing STEP files => Data Exchange - Problem importing STEP files
2020-03-18 11:16kgvTarget Version => 7.5.0*
2020-03-18 15:24kgvNote Added: 0091033
2020-03-18 15:40robertlipmanNote Added: 0091035
2020-03-18 20:07robertlipmanNote Added: 0091039
2020-03-19 15:59gkaAssigned Togka => dpasukhi
2020-03-19 15:59gkaStatusnew => assigned
2020-03-25 11:13gitNote Added: 0091233
2020-03-25 12:56gitNote Added: 0091238
2020-03-25 19:42gitNote Added: 0091248
2020-03-25 20:06gitNote Added: 0091249
2020-03-26 19:18gitNote Added: 0091284

Notes
(0091033)
kgv   
2020-03-18 15:24   
> LIMITS_AND_FITS entity. Blank values are valid.
Could you please comment, why blank values should be considered valid?

shape_tolerance_schema.exp (ISO 10303-242:2014) defines this entity like, with no OPTIONAL fields:
ENTITY limits_and_fits;
  form_variance : label;
  zone_variance : label;
  grade : label;
  source : text;
END_ENTITY;

Do I refer to the wrong schema in specs or mistreat its definition?
Or maybe schema has been revised within ISO 10303-242:2014/Cor 1:2016?
(0091035)
robertlipman   
2020-03-18 15:40   
Modifying the limits_and_fits entity to include values for 'grade' and 'source' still results in the same error in CAD Assistant. I tested many ideas to overcome the error. The only thing that worked was to remove the limits_and_fits entity.

In the STEP file, there are probably other required text fields that are blank that do not cause a problem.
(0091039)
robertlipman   
2020-03-18 20:07   
We came up with a workaround. If STEPCAFControl_Reader fails, then use STEPControl_Reader instead.
(0091233)
git   
2020-03-25 11:13   
Branch CR0031435 has been created by dpasukhi.

SHA-1: 1b4063309e05ec8cad0e0821dc5e53ad6b452f3a


Detailed log of new commits:

Author: unloguc
Date: Wed Mar 25 11:12:30 2020 +0300

    Fix overflow & empty grade
(0091238)
git   
2020-03-25 12:56   
Branch CR0031435 has been updated by dpasukhi.

SHA-1: 72313fec4fd4091fe737bb9e1b8ffba84b9fcfc3


Detailed log of new commits:

Author: dpasukhi
Date: Wed Mar 25 12:54:53 2020 +0300

    Changing the programs code in accordance with the rules

(0091248)
git   
2020-03-25 19:42   
Branch CR0031435 has been updated forcibly by dpasukhi.

SHA-1: b20063c522712eb431a2dd5d0ed691940053dc0c
(0091249)
git   
2020-03-25 20:06   
Branch CR0031435 has been updated forcibly by dpasukhi.

SHA-1: 8ed457984fe36b88b77a7b4eb80800bf243e97bb
(0091284)
git   
2020-03-26 19:18   
Branch CR0031435 has been updated forcibly by dpasukhi.

SHA-1: 8bf4df8c0be1145ba6714d98913f0abe984b49c4