MantisBT
Mantis Bug Tracker Workflow

View Revisions: Issue #31668 All Revisions ] Back to Issue ]
Summary 0031668: Visualization - WebGL sample doesn't work on Emscripten 1.39
Revision 2020-07-16 16:55 by kgv
Description Building WebGL sample using latest Emscripten release 1.39 switched from fastcomp to upstream (LLVM) toolchain results in numerous errors and non-working input.

First blocking error:
Uncaught (in promise) DOMException: Document.querySelector: '0' is not a valid selector occt-webgl-sample.js:9416



next error specific to eglSetSwapInterval():
emscripten_set_main_loop_timing: Cannot set timing mode for main loop since a main loop does not exist! 
Call emscripten_set_main_loop first to set one up.


another one related to eglGetProcAddress() for functions required by OpenGL ES 3.0 specs:
TKOpenGl | Type: Error | ID: 0 | Severity: High | Message:
  Error! OpenGL context reports version 3.0 but does not export required functions for 3.0 (glMapBufferRange)

Please report this issue to OpenGL driver vendor 'mozilla'


Revision 2020-07-16 16:10 by kgv
Description Building WebGL sample using latest Emscripten release switched from fastcomp to upstream (LLVM) toolchain results in numerous errors and non-working input.

First blocking error:
Uncaught (in promise) DOMException: Document.querySelector: '0' is not a valid selector occt-webgl-sample.js:9416



next error specific to eglSetSwapInterval():
emscripten_set_main_loop_timing: Cannot set timing mode for main loop since a main loop does not exist! 
Call emscripten_set_main_loop first to set one up.


another one related to eglGetProcAddress() for functions required by OpenGL ES 3.0 specs:
TKOpenGl | Type: Error | ID: 0 | Severity: High | Message:
  Error! OpenGL context reports version 3.0 but does not export required functions for 3.0 (glMapBufferRange)

Please report this issue to OpenGL driver vendor 'mozilla'




Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker