MantisBT
Mantis Bug Tracker Workflow

View Revisions: Issue #29859 All Revisions ] Back to Issue ]
Summary 0029859: Coding - GCC compiler warning -Warray-bounds in IntPatch_InterferencePolyhedron.cxx
Revision 2018-06-29 13:51 by bugmaster
Description
OCCT-ARCH463-64-opt-compile
IntPatch_InterferencePolyhedron.cxx:905, GNU C Compiler 4 (gcc), Priority: Normal
array subscript is above array bounds [-Warray-bounds]

This looks as real issue (even if not affecting anything): the cycle copies too many elements of array, so the last copy will be for uninitialized data (but still in the buffer, thus no actual out of bounds error).
Revision 2018-06-12 22:14 by abv
Description See 0029106:0075439:

OCCT-ARCH463-64-opt-compile
IntPatch_InterferencePolyhedron.cxx:905, GNU C Compiler 4 (gcc), Priority: Normal
array subscript is above array bounds [-Warray-bounds]

This looks as real issue (even if not affecting anything): the cycle copies too many elements of array, so the last copy will be for uninitialized data (but still in the buffer, thus no actual out of bounds error).


Copyright © 2000 - 2020 MantisBT Team
Powered by Mantis Bugtracker